自动画虚线指标

怎么在通达信主图自动划趋势通道指标

{自用的,供参考}

A93:=(REF(H,20)) = (HHV(H,((40) + 1)));

A94:=FILTER(A93,20);

A95:=BACKSET(A94,(21));

A96:=FILTER(A95,20);

A97:=(REF(L,20)) = (LLV(L,((40) + 1)));

A98:=FILTER(A97,20);

A99:=BACKSET(A98,(21));

A100:=FILTER(A99,20);

A101:=((REF((LLV(L,(40))),1)) + (REF((HHV(H,(40))),1))) / 2;

A102:=((A96 AND NOT((A100 AND (A101>=(H+L)/2)))) OR (ISLASTBAR)) OR (BARSCOUNT(C) = 1);

A103:=A100 AND NOT((A96 AND (A101 <(H+L)/2)));

A104:=(REF(BARSLAST(A102),1)) + 1;

A105:=BACKSET((A102 AND ((COUNT(A103,A104)) > 0)),(LLVBARS((IF(A103,L,10000)),A104)));

A106:=A105 > (REF(A105,1));

A107:=BACKSET(A106,2);

A108:=A107 > (REF(A107,1));

A109:=(A108 OR (ISLASTBAR)) OR (BARSCOUNT(C) = 1);

A110:=(REF(BARSLAST(A109),1)) + 1;

A111:=BACKSET((A109 AND ((COUNT((A96 AND NOT((A100 AND (A101 >=(H+L)/2)))),A110)) > 0)),(HHVBARS((IF((A96 AND NOT((A100 AND (A101 >=

(H+L)/2)))),H,0)),A110)));

A112:=A111 > (REF(A111,1));

A113:=BACKSET(A112,2);

A114:=A113 > (REF(A113,1));

A115:=BACKSET((ISLASTBAR),(BARSLAST(A114) + 1));

A116:=A115 > (REF(A115,1));

A117:=BACKSET((ISLASTBAR),(BARSLAST(A108) + 1));

A118:=A117 > (REF(A117,1));

A119:=BACKSET(A116,((REF(BARSLAST(A114),1)) + 2));

A120:=A119 > (REF(A119,1));

A121:=BACKSET(A118,((REF(BARSLAST(A108),1)) + 2));

A122:=A121 > (REF(A121,1));

DRAWLINE(A120,H,A116,H,1),COLOR00FF00 ;

DRAWLINE(A122,L,A118,L,1),COLOR0000FF;

谁知道大智慧分时主图自动画线指标如何编写?

和k线用的一样,只是在分时界面引用而已

通达信指标中如何自动画线

自动画线太多了,给你一个我看好的,源码下面网址里有图片演示.
该指标能够做到对前期高点和最近高点的连线、前期低点和最近低点的连线、阻力位和支撑位的平行直线的连线,可以说简单易懂,一目了然。这类指标要用到未来函数,通常不做为买卖信号的参考。但该指标在一定周期内根据K线的走势所画的线已经成立,因此股价突破前高或颈线的点位还是比较可靠的,大家不妨在实战中来验证。所以,除了主图以外,还编制了选股指标。
指标中的实线为高、低点连线,虚线为阻力位和支撑位。
该指标可以复制粘贴到任何主图里。
MA7:MA(C,7),COLORWHITE;
MA14:MA(C,14),COLORYELLOW;
MA25:MA(C,25),COLORFF00FF;
MA120:MA(C,120),COLORFFCC66;
QA:=REF(H,10)=HHV(H,2*10+1);
QB:=BACKSET(QA,10+1);
QC:=FILTER(QB,10) AND H=HHV(H,10+1);
QD:=BARSLAST(QC);
QE:=IF(QC,CURRBARSCOUNT,0);
QF:=IF(QD,REF(QE,QD),QE);
QG:=CONST(QF);
QH:=REF(QF,QD+1);
QW:=CONST(QH);
DRAWLINE(CURRBARSCOUNT=QW,H,CURRBARSCOUNT=QG,H,1),COLORGREEN;
DRAWLINE(CURRBARSCOUNT=QW,H,ISLASTBAR,REF(H,QW-1),1),COLOR0099FF,POINTDOT;
DRAWLINE(CURRBARSCOUNT=QG,H,ISLASTBAR,REF(H,QG-1),1),COLOR0099FF,POINTDOT;
QM:=INTPART(3*8/5);
QR:=REF(H,QM)=HHV(H,2*QM+1);
QT:=FILTER(QR,QM);
QY:=BACKSET(QT,QM+1);
QU:=FILTER(QY,QM);
QI:=BACKSET(ISLASTBAR,BARSLAST(QU)+1);
QP:=QI>REF(QI,1);
DRAWLINE(QU,H,QP,H,1),COLORRED;
QA1:=REF(L,8)=LLV(L,2*8+1);
QB1:=BACKSET(QA1,8+1);
QC1:=FILTER(QB1,8) AND L=LLV(L,8+1);
QD1:=BARSLAST(QC1);
QE1:=IF(QC1,CURRBARSCOUNT,0);
QF1:=IF(QD1,REF(L,QD1),L);
QG1:=IF(QD1,REF(QE1,QD1),QE1);
QH1:=CONST(QG1);
QW1:=REF(QF1,QD1+1);
QM1:=REF(QG1,QD1+1);
QR1:=CONST(QM1);
DRAWLINE(CURRBARSCOUNT=QR1,L,CURRBARSCOUNT=QH1,L,1),COLORBLUE;
DRAWLINE(CURRBARSCOUNT=QH1,L,ISLASTBAR,REF(L,QH1-1),1),COLORWHITE,POINTDOT;
DRAWLINE(CURRBARSCOUNT=QR1,L,ISLASTBAR,REF(L,QR1-1),1),COLORWHITE,POINTDOT;
QT1:=REF(L,QM)=LLV(L,2*QM+1);
QY1:=FILTER(QT1,QM);
QU1:=BACKSET(QY1,QM+1);
QI1:=FILTER(QU1,QM);
QP1:=BACKSET(ISLASTBAR,BARSLAST(QI1)+1);
QJ1:=QP1>REF(QP1,1);
DRAWLINE(QI1,L,QJ1,L,1),COLORRED;
SR1:=REF(HIGH,10)=HHV(HIGH,2*10+1);
SR2:=FILTER(SR1,10);
SR3:=BACKSET(SR2,10+1);
HD:=FILTER(SR3,10);
前高:=REF(H,BARSLAST(HD));
DRAWICON(CROSS(C,前高),L-0.20,3);{突破前高的信号}

怎样在指标公式k线中画竖虚线指标公式理想论坛

A:=CURRBARSCOUNT=10;
STICKLINE(A,C,H+1,0,-1),COLORFFFFFF;
上面是例子,根据你的需要自己修改就可以了。

通达信指标中如何自动画线

自动画线太多了,给你一个我看好的,源码下面网址里有图片演示.
该指标能够做到对前期高点和最近高点的连线、前期低点和最近低点的连线、阻力位和支撑位的平行直线的连线,可以说简单易懂,一目了然。这类指标要用到未来函数,通常不做为买卖信号的参考。但该指标在一定周期内根据K线的走势所画的线已经成立,因此股价突破前高或颈线的点位还是比较可靠的,大家不妨在实战中来验证。所以,除了主图以外,还编制了选股指标。
指标中的实线为高、低点连线,虚线为阻力位和支撑位。
该指标可以复制粘贴到任何主图里。
MA7:MA(C,7),COLORWHITE;
MA14:MA(C,14),COLORYELLOW;
MA25:MA(C,25),COLORFF00FF;
MA120:MA(C,120),COLORFFCC66;
QA:=REF(H,10)=HHV(H,2*10+1);
QB:=BACKSET(QA,10+1);
QC:=FILTER(QB,10) AND H=HHV(H,10+1);
QD:=BARSLAST(QC);
QE:=IF(QC,CURRBARSCOUNT,0);
QF:=IF(QD,REF(QE,QD),QE);
QG:=CONST(QF);
QH:=REF(QF,QD+1);
QW:=CONST(QH);
DRAWLINE(CURRBARSCOUNT=QW,H,CURRBARSCOUNT=QG,H,1),COLORGREEN;
DRAWLINE(CURRBARSCOUNT=QW,H,ISLASTBAR,REF(H,QW-1),1),COLOR0099FF,POINTDOT;
DRAWLINE(CURRBARSCOUNT=QG,H,ISLASTBAR,REF(H,QG-1),1),COLOR0099FF,POINTDOT;
QM:=INTPART(3*8/5);
QR:=REF(H,QM)=HHV(H,2*QM+1);
QT:=FILTER(QR,QM);
QY:=BACKSET(QT,QM+1);
QU:=FILTER(QY,QM);
QI:=BACKSET(ISLASTBAR,BARSLAST(QU)+1);
QP:=QI>REF(QI,1);
DRAWLINE(QU,H,QP,H,1),COLORRED;
QA1:=REF(L,8)=LLV(L,2*8+1);
QB1:=BACKSET(QA1,8+1);
QC1:=FILTER(QB1,8) AND L=LLV(L,8+1);
QD1:=BARSLAST(QC1);
QE1:=IF(QC1,CURRBARSCOUNT,0);
QF1:=IF(QD1,REF(L,QD1),L);
QG1:=IF(QD1,REF(QE1,QD1),QE1);
QH1:=CONST(QG1);
QW1:=REF(QF1,QD1+1);
QM1:=REF(QG1,QD1+1);
QR1:=CONST(QM1);
DRAWLINE(CURRBARSCOUNT=QR1,L,CURRBARSCOUNT=QH1,L,1),COLORBLUE;
DRAWLINE(CURRBARSCOUNT=QH1,L,ISLASTBAR,REF(L,QH1-1),1),COLORWHITE,POINTDOT;
DRAWLINE(CURRBARSCOUNT=QR1,L,ISLASTBAR,REF(L,QR1-1),1),COLORWHITE,POINTDOT;
QT1:=REF(L,QM)=LLV(L,2*QM+1);
QY1:=FILTER(QT1,QM);
QU1:=BACKSET(QY1,QM+1);
QI1:=FILTER(QU1,QM);
QP1:=BACKSET(ISLASTBAR,BARSLAST(QI1)+1);
QJ1:=QP1>REF(QP1,1);
DRAWLINE(QI1,L,QJ1,L,1),COLORRED;
SR1:=REF(HIGH,10)=HHV(HIGH,2*10+1);
SR2:=FILTER(SR1,10);
SR3:=BACKSET(SR2,10+1);
HD:=FILTER(SR3,10);
前高:=REF(H,BARSLAST(HD));
DRAWICON(CROSS(C,前高),L-0.20,3);{突破前高的信号}

请高手帮我做个主图的自动划线公式,很简单的,先谢谢了!

KX:DRAWKLINE(H,O,L,C);
ZG:IF(HHV(H,60),CONST(HHV(H,60)),DRAWNULL),COLORWHITE;
ZD:IF(LLV(L,60),CONST(LLV(L,60)),DRAWNULL),COLORGREEN;